Strange REN problem - non-English characters

May 20, 2008
3,515
4
Elkridge, MD, USA
I was trying to rename PALLAS00.DOC to Bevezetés.doc (note the special,
non-ASCII character in the target name). Instead, the command tried to
rename the document to itself. 10.00.57 and 8.02.106 behaved identically.

I finally succeeded by creating a hard link from the existing name to the
desired name, and deleting the original name.

WinXP SP3.
--
Steve
 

dim

Dimitry Andric
May 31, 2008
205
1
Netherlands
On 2009-03-06 17:22, Steve Fábián wrote:

> I was trying to rename PALLAS00.DOC to Bevezetés.doc (note the special,
> non-ASCII character in the target name). Instead, the command tried to
> rename the document to itself. 10.00.57 and 8.02.106 behaved identically.

No such problems here (build 10.00.57):

D:\Test>echo foo > PALLAS00.DOC

D:\Test>dir *.doc
2009-03-06 17:54 5 PALLAS00.DOC

D:\Test>ren PALLAS00.DOC Bevezetés.doc
D:\Test\PALLAS00.DOC -> D:\Test\Bevezetés.doc
1 file renamed

D:\Test>dir *.doc
2009-03-06 17:54 5 Bevezetés.doc

D:\Test>echo foo > PALLAS00.DOC

D:\Test>dir *.doc
2009-03-06 17:54 5 PALLAS00.DOC

D:\Test>ren PALLAS00.DOC Bevezetés.doc
D:\Test\PALLAS00.DOC -> D:\Test\Bevezetés.doc
1 file renamed

D:\Test>dir *.doc
2009-03-06 17:54 5 Bevezetés.doc
 

rconn

Administrator
Staff member
May 14, 2008
12,316
148
Steve Fábián wrote:

> I was trying to rename PALLAS00.DOC to Bevezetés.doc (note the special,
> non-ASCII character in the target name). Instead, the command tried to
> rename the document to itself. 10.00.57 and 8.02.106 behaved identically.

Not reproducible here -- what is the *exact* syntax you're using?

Rex Conn
JP Software
 
May 20, 2008
3,515
4
Elkridge, MD, USA
rconn wrote:
| Steve Fábián wrote:
|
|
| ---Quote---
|| I was trying to rename PALLAS00.DOC to Bevezetés.doc (note the
|| special, non-ASCII character in the target name). Instead, the
|| command tried to rename the document to itself. 10.00.57 and
|| 8.02.106 behaved identically.
| ---End Quote---
| Not reproducible here -- what is the *exact* syntax you're using?

Sorry, the mistake was a mistype which my eyesight could not detect - the
exact command I used was (copy and paste)

*ren PALLAS00.DOC Bevezetés,*

which had a comma where a period should have been. I only caught it now,
when I used a much larger font.
--
Steve
 
Similar threads
Thread starter Title Forum Replies Date
R strange bug? Support 7
Jesse Heines Strange Line Wrapping Behavior Support 14
F strange results Support 9
M Strange error messages from TCC in FTP copy Support 7
M Another possibly strange remote registry issue Support 5
forbin Strange handling of [nonbright] magenta background (v22) Support 2
N Fixed Strange dir behavior Support 6
vefatica REGDIR, strange error message Support 7
T WAD Strange Unexpected "features" in the Debugger Support 2
P Strange mouse behavior with list Support 2
vefatica Strange tcc.exception.log Support 7
vefatica A strange one Support 0
D Strange DO behavior with /O Support 5
Glenn Bowes Strange text at startup Support 5
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
vefatica Big numbers, strange errors Support 1
aedthuio Strange... lpksetup Support 4
CWBillow dir /4 strange Support 2
D Strange issue with FOR loop Support 15
MikeBaas Strange prob with %@replace.. Support 4
vefatica OT: strange files in %TEMP Support 10
Dan Glynhampton Documentation v15 help: Strange links in @INT topic Support 0
R WAD Strange output from "memory" command Support 1
M Yet another strange something re something called "@TCONVERT" Support 8
Roedy How to? Strange colours Support 9
M WAD Strange "Start" misbehavior... Support 10
vefatica Very strange console font corruption Support 3
Steve Pitts Strange problem with FREE Support 10
A strange error in alias Support 9
newgeekorder Debugger IDE - strange tab and parameter behaviour Support 1
Exolon Strange Prompt. Support 6
vefatica Strange folders Support 1
T Strange CPU value Support 3
J Strange error: unset /s Support 14
M Strange behavior... Support 2
CWBillow Strange happenings Support 2
B Strange handling of a .BAT file Support 5
vefatica Strange behavior reloading SHRALIAS sav files. Support 1
J ASSOC / FTYPE strange error message Support 3
D Strange crashes in @CRC32 and @MD5 Support 9
Charles Dye Strange output, here-doc redirection, TYPE, //UnicodeOutput=Yes Support 6
S Strange CHKDSK behavior Support 6
vefatica Strange results with CP 1252 Support 12
dcantor Strange status in ACTIVATE command Support 0
Jesse Heines Using Regular Expressions with the REN commanc Support 8
C Documentation Help Nit. REN / RENAME Support 0
D How to? Use regular expression with REN? Support 2
vefatica REN and NTFS streams? Support 3
samintz REN implied .* Support 2
F Regexes in REN/MOVE/… commands seem to not work at all Support 3

Similar threads