1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TCC17 background color problem

Discussion in 'Support' started by vr8ce, Dec 3, 2014.

  1. vr8ce

    Joined:
    Jun 16, 2009
    Messages:
    13
    Likes Received:
    0
    TCC 17.00.62 on Win 7 [Version 6.1.7601].

    This is almost certainly trivial and obvious, so apologies in advance.

    I've been a user since the earliest of days, and I've been on TCMD/TCC 10.x for quite some time now. I finally decided to upgrade, and bought 17 today. I copied my tcmd.ini from my 10 directory to 17, then fired up TCC. I set the background on the session to blue like always, and made a few other adjustments to font size, etc.

    The problem is the blue background doesn't stick, e.g. when I do a directory, everything after the first screensize lines has a blue background on the text itself, but not the rest of the line (see attached). As a data point, the same thing happens with TCMD17, but I don't use TCMD very often.

    This doesn't happen with TCC 10 (or CMD); it's all blue background, all the time. I remember seeing this type of problem in the very olden days of DOS, but I haven't encountered it in so long I don't remember what to do to fix it. I tried checking and unchecking ANSI Colors in Option; neither helped.

    What do I not remember?

    Thanks!

    Update: Weird. This just started working in TCC17. I did a directory, it did what the picture showed for a few lines, then went back to a solid blue. Subsequent operations showed all solid blue. I exited TCC17 and started a new session, which also worked, i.e. has solid blue background all the time. I made no changes to anything.

    The problem still exists in TCMD17. I exited and started a new session after it started working in TCC17, but the problem persists in TCMD.
     

    Attached Files:

    #1 vr8ce, Dec 3, 2014
    Last edited: Dec 3, 2014
  2. Rod Savard

    Joined:
    May 26, 2008
    Messages:
    481
    Likes Received:
    3
    Out of curiosity where are you setting the color? If you are setting it using the standard console window properties dialog (the only location available when setting colors for cmd.exe, powershell.exe, etc), I think that may be your problem. For standalone TCC try typing OPTION and setting the colors on the "Windows" tab.

    Just a guess...
     
  3. vr8ce

    Joined:
    Jun 16, 2009
    Messages:
    13
    Likes Received:
    0
    Sorry, I should have said — both places, actually. The color is set in OPTION, and it's set on the console properties.
     

Share This Page