Remaining TCMD background process (v26) ...

Jan 12, 2014
422
7
Switzerland, SO
Hi

I'm not sure, if this is a bug. However, I decided to make this post to inform you ...

This was the at least the 2nd time since v26 that after closing Take Command a background process was still there.

tc-cpu.PNG


What I can say is: both times I had also the help file open - and also, I started Take Command several times (also TCC, but this is probably not related).

Once again, I am not sure, if this is a bug, at least not if this is related to Take Command itself or (more) to the help file ... it's just an info for you.
 
May 20, 2008
11,378
98
Syracuse, NY, USA
I can reproduce it, but not dependably. It involves having more than one TCMD running, at least one Help showing, and X-ing one of the TCMDs. The zombied TCMD uses all of one processor. I have no TCEXIT script.

I also noticed this. Start two TCMDs; open the help in one TCMD; X the other TCMD ... the help closes. WAD?
 

rconn

Administrator
Staff member
May 14, 2008
12,340
149
I also noticed this. Start two TCMDs; open the help in one TCMD; X the other TCMD ... the help closes. WAD?

WAD in the sense that:

1) It's behaved this way for at least 20 years, and
2) It's out of my control - that's what Windows does when you use the HtmlHelp APIs. TCC (and TCMD) don't do anything to close the help window.
 
May 20, 2008
11,378
98
Syracuse, NY, USA
WAD in the sense that:

1) It's behaved this way for at least 20 years, and
2) It's out of my control - that's what Windows does when you use the HtmlHelp APIs. TCC (and TCMD) don't do anything to close the help window.
It doesn't happen with TCC. The only TCC whose closing will close the help is the TCC which opened the help.
 

rconn

Administrator
Staff member
May 14, 2008
12,340
149
It doesn't happen with TCC. The only TCC whose closing will close the help is the TCC which opened the help.

That's right, it doesn't happen with TCC. Console apps and GUI apps are different.

Whenever I've tried to replace the (awful outdated unsupported) CHM help file format, one of the beta testers bombards me with dozens of messages that his IE 8 configuration was changed.

Radical thought - use web help. Problem solved.
 
May 20, 2008
11,378
98
Syracuse, NY, USA
I'm still trying to reproduce the zombie thingy. I managed to do it once more, writing down my steps. The same steps didn't make it happen again.
 
Jan 12, 2014
422
7
Switzerland, SO
@rconn
Well, the reproducable steps were easy HERE:

1. Open TCMD
2. Open help (via help command)
3. Close TCMD (help closes automatically as desired).

And voila, a background process remains.

PS: I thought, I had already tested those steps 2 days ago or so and couldn't reproduce it, but at least at the moment, I have each time this behaviour. So it seems, it's definitively related to the open help.
 

rconn

Administrator
Staff member
May 14, 2008
12,340
149
Still can't reproduce it here. However, working under the assumption that it's a recent Win 10 bug with html help (which wouldn't be surprising since MS dropped support long ago), I added an experimental fix to build 30.

Try build 30 (already uploaded) and let me know if it works for you.
 
May 20, 2009
293
5
57
ITALY
Generally I use TCC and not TC, but since so far I have not contributed to this forum for v26, here are my two cents.
On my pc with windows 10 English 64 pro 1909 I have this "issue", even with build 30, with a "ghost" tcmd process.

Thank You and regards

Rodolfo Giovanninetti
 
May 20, 2009
293
5
57
ITALY
How are you invoking the help?
I followed Alpengreis instructions.
Start TC (in my case it opens one tab with TCC).
Type the help command.
Close TC.
It closes the TC window and the help window, but there is still a tcmd process.

Regards

Rodolfo Giovanninetti
 
May 20, 2009
293
5
57
ITALY
Please try this again with build 31 (already uploaded). Still can't reproduce it here, but trying another potential workaround.
It seems to work also on my pc.
Please let me explain.
Am I able to reproduce this "issue"?
Yes, meaning that it happened more than once.
No, meaning that I cannot say that it happened always.
Maybe it happened always and in one case I did not see the ghost process.
What I noticed is that the ghost process kept the same pid.
And that it used 25% of the cpu.
With build 31 I have not been able to reproduce it.

Thank You and regards

Rodolfo Giovanninetti
 
Similar threads
Thread starter Title Forum Replies Date
W The skipping of remaining 4NT job steps Support 2
vefatica TCMD hides itself! Support 3
vefatica Tray min'd TCMD and ACTIVATE Support 6
C How to? starting TCC/TCMD v25 Support 2
CWBillow TCC and TCMD in Powershell Support 6
kb6ojs How to? "Specified Account Already Exists" error installing TCMD v27 Support 12
CWBillow TCMD Colors Support 8
Jay Sage Issues With TCMD File Explorer Support 0
C Last TCMD that supports win 7? Support 5
gentzel TCMD background color confusion Support 6
R Upgrade TCMD 19 to TCC 26 Support 1
S Windows Server version not being detected correctly in TCMD 26RC2 Support 9
G TCMD crash when copy Support 3
Joe Caverly DrawVLine results different in TCMD tab and detached TCC Support 11
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
Jay Sage TCMD Crashes with "tctoolbar /c /r file" Support 5
nikbackm TCMD 25 - Unregister older TCMD version Support 2
G Documentation on TCMD.INI Support 9
R New Clear Buffer in TCMD Home Menu Support 2
CWBillow Back up TCMD tabs Support 2
CWBillow Upgrade Windows 10's effect on TCMD and TCC Support 3
DrusTheAxe TCMD 24.02.49 x64 crashed due to DivideByZero :-( Support 4
A After update to 24.02.49, helpfile tcmd.chm hangs when opened Support 0
David McClelland TCMD 24 & Perl - perl thinks it's own executable is ...\TCMD24\TCC.EXE??? Support 3
dcantor How to? Can 32-bit TCC be run on a system with 64-bit TCMD and TCC installed? Support 6
W pdir returns diff results between tcc and tcmd - one is an error msg Support 5
vefatica What's TCMD's problem with ^e[0m? Support 13
CWBillow TCMD PowerShell Tab elevated Support 6
A How to? Copy+Paste in TCMD tabs with Ctrl-Shift-Ins? Support 5
vefatica TCMD output invisible on Win10 Support 22
J Moving from TCC v22 to TCMD v24 issues Support 3
RChrismon How to? Copy TCMD.INI to New Version Support 7
rps TCMD OPTIONS dialog Support 2
rps TCMD Tabs priority option setting Support 0
D Can we fix the scaling for TCmd? Support 14
CWBillow TCMD Tab Defs Support 4
A How to? TCMD Configuration Dialog: 'Smooth Scrolling' Option missing? Support 1
A Fixed [23.0.22]: TCMD crashes shortly after start, TCC keeps running in background Support 6
A TCMD - Dir Command puts out blank lines? Support 16
P Symantec Endpoint Protection trapped TCMD.EXE and said it contained WS.Reputation.1 (Virus?) Support 3
Emilio III TCMD Tab titles on Insider Windows Support 2
kb6ojs Want to start TCMD v20 with every Windows 10 bootup Support 3
D Tcmd 22.00.42 - annoying desktop refresh Support 47
CWBillow Context menu extensions for TCC/TCMD v18? Support 1
vefatica Pasting into TCMD via right-click menu? Support 2
M Please explain TCMD's ANSI x3.64 support Support 4
CWBillow Powershell tab in TCMD? Support 2
D Custom ini-file is not read, by tcmd.exe cli Support 6
R TCC-RT with TCMD installed Support 6

Similar threads