"View" settings still not remembered

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
When I first started TCMD build 46 there was no file explorer and no status bar (my preference). Then I checked View\FileExplorer and View\StatusBar and they both showed up. Then I closed TCMD and ran it again. There was no FileExplorer and no StatusBar even though both were checked in the View menu. And at this point, the "FileExplorer" button, which I had put on the QuickAccess toolbar was lit up, as if the FileExplorer was shown.

In another experiment, I removed the "FileExplorer" button from the QA toolbar ... closed TCMD and started it again ... the button was back!
 

rconn

Administrator
Staff member
May 14, 2008
10,096
85
#3
When I first started TCMD build 46 there was no file explorer and no status bar (my preference). Then I checked View\FileExplorer and View\StatusBar and they both showed up. Then I closed TCMD and ran it again. There was no FileExplorer and no StatusBar even though both were checked in the View menu. And at this point, the "FileExplorer" button, which I had put on the QuickAccess toolbar was lit up, as if the FileExplorer was shown.

In another experiment, I removed the "FileExplorer" button from the QA toolbar ... closed TCMD and started it again ... the button was back!
Not reproducible here (any of that). And TCMD isn't controlling the QA toolbar.
 
#4
IIRC, this is how the other related thread started. Then others chimed in with observations of the same problem.

What should I delete from the registry to start afresh?
 
#6
After deleting
Code:
HKEY_CURRENT_USER\Software\JP Software\Take Command 19.0 x86
and letting TCMD re-create it, things are better ... but not perfect.

StatusBar enabled/disabled is now remembered.

But ... I check View\FileExplorer, FileExplorer opens, not in auto-hide mode (pushpin pointing down) and the tab window shrinks accordingly. Then I close TCMD and restart it. FileExplorer is still enabled (better than before) but it's hidden and set to auto-hide. Can't I start TCMD with FileExplorer showing and not in auto-hide mode?
 
Jul 7, 2008
17
1
#7
I'm now seeing a similar problem. I prefer the toolbar ribbon minimized, but with the latest patch that option doesn't persist between launches of tcc. My specs are:

TCC 19.10.46 x64 Windows 10 [Version 6.3.10586]
TCC Build 46 Windows 10 Build 10586

[edit: I posted this in the related "oddity" topic after realizing it was more specific to this particular issue.]
 
Jul 7, 2008
17
1
#9
Click on View / Minimize Ribbon.
Apparently I didn't make myself clear. I know how to minimize the ribbon. I can click on the View->Minimize Ribbon checkbox and it does minimize the ribbon. But only for the duration of that session; the setting doesn't seem to persist. If I close TCC and restart it the ribbon bar reappears.
 
May 20, 2008
420
2
#10
I'm resurrecting this as I have a similar issue on Win10x64. It works fine on my main OS, but Win10x64 under Hyper-V doesn't persist the minimized ribbon.