1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bdebugger / IDE editor doesn't display called batch file

Discussion in 'Support' started by Berndt Berg, Mar 2, 2011.

  1. Berndt Berg

    Joined:
    Jun 2, 2008
    Messages:
    21
    Likes Received:
    0
    TCC 12,01,44 Windows XP [Version 5,1,2600]
    TCC Build 44 Windows XP Build 2600 Service Pack 3

    Using swedish keyboard and Regional and Language Options: Swedish

    When running z1.btm below in bdebugger / IDE the called batch file z2.btm is never displayed in the IDE-window though it seems as z2.btm is executed.
    On screen the cursor is going up to the first line when I press F11 on the call z2.btm statement and for each single step the z2.btm file is executed but I only see z1.btm contents in the IDE-window.

    Reproducible: Always.

    This behaviour is only applicable to version 12. In TCMD version 11 the z2.btm contents is properly displayed.

    Batch file z1.btm
    ----------------
    echo off
    echo This is first file
    echo Calling second file
    call z2.btm
    echo Returning from second file
    quit

    Batch file z2.btm
    ----------------
    echo off
    echo This is second file
    echo Returning to first file
    quit

    Best regard
    Berndt Berg
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,868
    Likes Received:
    83
    Confirmed. I've fixed it in the next build (which should be released sometime next week).
     

Share This Page