Problem With SCRPUT /u

May 2, 2013
13
0
I am having a problem with inconsistent behaviour with SCRPUT /u. For example, using the following batch file (the problem isn't restricted to this batch file; it happens in others, and at the command prompt as well):
2300

I get the expected output for the first nine times (always nine time) I run it, as follows:
2297

After nine runs, the output becomes erratic with random numbers of blank lines between the SCRPUT'ed lines. The final output - "Input folder", etc - was 15 (!) blank screens further down, but sometimes the amount of space between is different.
2298


After two (always two) runs like that, the /u parameter no longer seems to have any effect:, and on all subsequent runs the cursor doesn't move with the result that additional output on a given line overwrites the first output:
2299


I am using version 24.02.46 under Windows 10. The same results happen in both TCC and the tabbed interface. Nothing about the batch file or system changes in between different runs. Restarting Take Command (or TCC) results in the batch file working correctly the first nine times, then getting output with blank lines between SCRPUTs, then the /u parameter being ignored.

The /u parameter is a great addition to SCRPUT and makes it far more useful, thank you for that. I would appreciate if you could investigate the issue.

Ken.
 
May 20, 2008
11,379
98
Syracuse, NY, USA
I have trouble using it once. On Win7/32, I get
2301


On Win10/64, the one time I tried it I got a over a thousand blank lines (about 56 PgDns) between "Usage" and %@name[...].
 
May 20, 2008
11,379
98
Syracuse, NY, USA
On both OSs, I can see the behavior that Ken described. It's not necessarily on the 10th try. It is precisely when the console begins to scroll.
 
Similar threads
Thread starter Title Forum Replies Date
Dick Johnson Weird Color Problem Support 8
fishman@panix.com Problem with 27.15 Support 2
M Problem with VSDevCmd.bat in VS 16.7.3 Support 0
R Problem with @INT[ value] in V26 Support 9
M Selecting test "off by one" problem in Take command Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
K_Meinhard Small problem in german IDE 26 Support 3
B Problem with color in nested shells Support 1
Joe Caverly Problem creating and switching to a DESKTOP Support 9
vefatica Another popup problem Support 10
Alpengreis ffind dialog (/W) problem Support 4
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
A Problem with functions @int @decimal and identifying Powershell as a shell. Support 12
B IF command problem in tcexit.btm Support 9
fishman@panix.com Problem at Startup of TCC Support 3
P Problem with SFTP copies Support 7
P Problem with FTP copies Support 10
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
R Problem with %_do_loop in nested do loops Support 2
fishman@panix.com New Problem with later Windows 10 Support 10
Peter Murschall A little problem with LEAVE and COMMENT Support 5
M Handling of %~I problem Support 4
WinLanEm FOR problem Support 18
vefatica What's TCMD's problem with ^e[0m? Support 13
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4
rps Regex problem: \xnn not recognized as a hex character Support 0
rps PRIORITY LOW problem Support 1
old coot Regex problem: \xnn not recognized as a hex character Support 12
vefatica Another problem with build 22. Support 3
Alpengreis [23.x] Download-Problem Support 2
S Problem with " Support 3
C Problem navigating forums Support 11
x13 Problem listing repository files using DIR http(s)://... Support 8
Joe Caverly Problem with TEE in v22 Support 2
Alpengreis Problem with thousands delimiter and colors Support 17
M Take Command 18, migrating to another machine, license problem. Support 1
B TCC 21.01.50 Problem with ALIAS /r and SET /r Support 2
rps How to? @search problem Support 2
WinLanEm @SELECT problem Support 6
T Fixed Problem with use of Batch parameters in the IDE Support 1
Oz Solomon Problem with "list" Support 14
S V21.24 theme problem Support 2
Alpengreis Problem if command prompt is not legacy Support 4
Alpengreis TCMD.INI: The "super hidden" problem ... Support 6
G Odd problem - screen brightness Support 4
rps V20 In-process pipes problem Support 8
Alpengreis Again theme problem [v20.0.21]? Support 11
WinLanEm INPUT problem Support 1
Craig Fitzgerald problem with executable extensons with TCC version 19.10.51 x64 Support 3

Similar threads