Problem with cygwin bash/emacs

Jul 25, 2008
3
0
I am running TCM 9.0 and open cygwin/bash command shells in the tabs. For some reason, emacs does not seem to get ctrl-space characters correctly (ASCII 0). When I run bash in its own regular cygwin window, it works fine, as it does when I use PuTTY to remote to another machine (SSH connection).

I checked the TCM options but can't find anything I should set.

Any ideas?

Thanks, Ralph
 
May 20, 2008
603
0
Sammamish, WA
There is a check box for left and right
Ctrl and shift keys if you are running tcmd -- these may help

Sent from Cookie's iPhone

On Jul 25, 2008, at 17:16, grkuntzmd <> wrote:


> I am running TCM 9.0 and open cygwin/bash command shells in the
> tabs. For some reason, emacs does not seem to get ctrl-space
> characters correctly (ASCII 0). When I run bash in its own regular
> cygwin window, it works fine, as it does when I use PuTTY to remote
> to another machine (SSH connection).
>
> I checked the TCM options but can't find anything I should set.
>
> Any ideas?
>
> Thanks, Ralph
>
>
 

rconn

Administrator
Staff member
May 14, 2008
12,113
138
grkuntzmd wrote:

> I am running TCM 9.0 and open cygwin/bash command shells in the tabs.
> For some reason, emacs does not seem to get ctrl-space characters
> correctly (ASCII 0). When I run bash in its own regular cygwin window,
> it works fine, as it does when I use PuTTY to remote to another machine
> (SSH connection).
>
> I checked the TCM options but can't find anything I should set.

Go to Options / Configure Take Command / Tabs and specify which keys you
want to send to Take Command versus the apps in the tab windows.

Rex Conn
JP Software
 
Thread starter Similar threads Forum Replies Date
fishman@panix.com Support 2
Charles S. Roaten Support 1
M Support 0
R Support 9
V Support 0