Problem with Extended Search and non-ASCII characters in directories names

Jul 21, 2014
6
0
France
#1
Hi,

It seems to me that the Extended Directory Search feature does not work well with non-ASCII characters in directories pathnames.

Note: the line "FuzzyCD=2" is present in the TCMD.INI.

Example:

Code:
E:\>md aaaa\eeee\bbbb

E:\>cd bbbb

E:\aaaa\eeee\bbbb>                # OK, the Extended Directory Search works well.
E:\aaaa\eeee\bbbb>cd \

E:\>md aaaa\éééé\cccc

E:\>cd cccc

TCC: (Sys) Le chemin d’accès spécifié est introuvable.       # "The specified path was not found"
"E:\aaaa\ツツツツ\cccc"

E:\>cd aaaa\éééé\cccc

E:\aaaa\éééé\cccc>                  # However, this directory exists
The problem exists with other non-ASCII characters too (à, ç, è, £, §, ...)

What can I do to fix this? Thank you.

Note: My E: drive is a NTFS partition.

Tests made with TCC 16.03.55 x64 and Windows 8.1 French Edition
Same results with TCC LE 13.06.77 x64.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,602
46
Albuquerque, NM
prospero.unm.edu
#2
I have not tested this, but it might be worth a try:

Code:
rem Delete the old index file:
del "%localappdata\jpstree.idx"

rem Turn on Unicode:
option //unicodeoutput=yes

rem Recreate the search index:
cdd /s

rem Turn off Unicode:
option //unicodeoutput=no
 
Jul 21, 2014
6
0
France
#3
Yes!
Code:
E:\>del e:\4NT\jpstree.idx /q        # I have "TreePath=E:\4NT" in my TCMD.INI

E:\>option //unicodeoutput=yes

E:\>cdd /s
Indexation de C:\
Indexation de D:\
Indexation de E:\

E:\>option //unicodeoutput=no

E:\>md aaaa\éééé\bbbb

E:\>cd bbbb

E:\aaaa\éééé\bbbb>            # It works!
Thanks for your help, Charles.