By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Fixed View and V do not work in new 13.04.52 x64 installation

Hi gang,

View and V do not work in new 13.04.52 x64 installation

TCC 13.04.52 x64 Windows 7 [Version 6.1.7601]
TCC Build 52 Windows 7 Build 7601 Service Pack 1
Registered to Steven Kraus - 1 System License

I just upgraded TCmd to v13 and had some issues. I was reading the Prompt Solution about the new View command and I also saw a coupon code for a $39 upgrade. Unfortunately the coupon code did not work after several tries, but I don't reallly mind paying $49. I installed v13.04 along side my existiing installation (as I've done in other upgrades). My old installation folder is C:\TC and my new folder was C:\TC13. I like the short names right off the root directory. I installed the shareware download and did not apply the registration code yet. I wanted to install it on a USB thumb drive first, then install it on my laptop hard drive where I do most of my work. I plugged in the thumb drive and checked that the ithumb drive was identified correctly as a removable drive using echo %@removable[H:] and it returned a 1. I also tried the VIEW command to view my alias file. It didn't work. I tried the V command to view the file. Nothing. No new window, no new tabs. I tried running the v.exe file using .\v.exe filename from the C:\TC13 folder where it was installed. Nothing. And I tried .\v.exe with no filename parameter. Nothing. I thought perhaps V is tied to the licensed distribution.

I uninstalled TCmd v13.04 using the Add / Remove Program from Windows 7 professional and it uninstalled. I left this dialog open so I could see the list of programs installed. I checked the C:\TC13 folder and found all program files removed, leaving only my alias and history and TCSTART.btm file that I had copied. Excellent, as expected. Then I installed TCmd on my removable thumb drive in folder H:\TC and it installed and I clicked the Register button on the startup, and typed in my registration information. I did not specify a desktop or a menu shortcut, because I intended to installl it on hard drive too. That worked. But checking the Add Program window, I could see the TCmd 13.04 was installed.

From the TCmd window, I tried the View and V commands unsuccessfully, with either an existing filename parameter or without. Nothing. Then I tried clicking the V on the toolbar and was gratified to see an open file dialog window titled VIEW. But selecting a file to view did nothing. No window and no new tab window. TYPE and LIST worked on the sample test file, but VIEW and V did not.

Next I tried installing the same installation file on hard drive on the C:\TC13 folder, and the installation said that it was installed, and I could repair it or remove TCmd. That was disappointing. I stopped the installation and after a couple of attempts, I tried Repair and found that it did install in C:\Program Files\JPSoft\TCMD13x64. My USB installation seems to have worked, and I was able to installed TCmd v13 on hard drive, but in the wrong folder. I like a short folder name that I can type quickly.

But View and V do not work.

Not reproducible here. When you run VIEW, are you returned immediately to the next prompt? Any error message? (Try "echo %_?" and let me know what that returns.)

What language are you using in Take Command / TCC? If it's not English, try switching to English, restart TCMD or TCC, and see if that changes the VIEW startup behavior.

Anybody else having problems with VIEW in 13.04.52?
Hi Rex,
Thanks for your immediate response and great support!

When running V or VIEW from the command prompt,
I am returned to the prompt immediately with no error message and %_? returns 0.
I switched languages from "Default" to "English", reboot and restarted TCmd. No changes.

I have no aliases called V or VIEW (I checked with if isalias)
And I have no VIEW.exe or V.exe files, except for v.exe in the installation folder.

The problem seems related to my two versions of TCmd and my initial try to install v13 into C:\TC13.
TCmd v12 is in C:\TC and I had COMSPEC=C:\TC\tcc.exe set in TCSTART.btm. I fixed that and set
COMSPEC=C:\Program Files\JPSoft\TCMD13x64\tcc.exe
And my TCSTART / TCEXIT path was C:\TC13
I set that to C:\Program Files\JPSoft\TCMD13x64

Then starting a new TCC window made VIEW from the command prompt open a file dialog box. However it still didn't work after selecting a file. And V does nothing. The toolbar V still doesn't work.

I'll try renaming the V12 version and checking the registry.
I'll also put debug statements into TCSTART.btm

Is the correct Registered User Name displayed when you select About Take Command from the Help menu?

Is there a file called V.log in C:\Users\YourUserName\AppData\Roaming\V ?

If there is, please send it to v at fileviewer.com

Can you please download the following diagnostic version:


Copy vdebug.exe to your Take Command folder and then CD to the Take Command folder and run "vdebug filename".

Then send me a copy of V.log which should be in C:\Users\YourUserName\AppData\Roaming\V (send to v at fileviewer.com)
(Note that this is a 64 bit program and will only run on 64 bit Windows.)

I have identical symptoms, except it was an upgrade from the previous rev of 13. I have tried removing my .ini and tcstart with no change. I have sent Charles the log file.
I have the same symptoms, but after downloading vdebug.exe there was no problem using vdebug.exe filename, and even when I renamed vdebug.exe to v.exe, I could do "view filename" properly, even "dir | view" works ok.

A sample log entry looks like this:

Windows Version 6.1 (Build 7601), Platform = 2
Version 13.1.11 TC - Test 1  (x64)
Command Line: v 
14-03-12 09:32:45 (29266161): Checking Take Command License
14-03-12 09:32:45 (29266161): Checking for LE
14-03-12 09:32:45 (29266177): ProductDescription1: Take Command, fLE=0
14-03-12 09:32:45 (29266177): Found PRO Version
14-03-12 09:32:45 (29266177): IsUSB: keyfile=C:\Program Files\JPSoft\TCMD13x64\V.EXE
14-03-12 09:32:45 (29266177): GetDriveType(C:\) = 3
14-03-12 09:32:45 (29266177): Not Removable1
14-03-12 09:32:45 (29266177): Reading name & key from registry
14-03-12 09:32:45 (29266193): Validating: George Schizas - 1 System License, ******************************
14-03-12 09:32:45 (29266193): Calling ValidateLicenseEx(******************************, TYPHOEUS)
14-03-12 09:32:45 (29266193): GetStatus = 2
14-03-12 09:32:45 (29266193): get_NumberOfLicenses=3
14-03-12 09:32:45 (29266193): PERMANENT key found
14-03-12 09:32:45 (29266208): ValidateTCLicense: bReturn = 1
14-03-12 09:32:45 (29266208): ValidateTCLicense = 1
14-03-12 09:32:45 (29266208): Checking Registered Users
14-03-12 09:32:45 (29266208): Registered to: George Schizas - 1 System License, nLicenses=3
14-03-12 09:32:45 (29266208): nFiles = 1
14-03-12 09:32:45 (29266208): ICalling ViewFile

(****************************** is a licence key obviously, Typhoeus is my PC name)
I believe I've found the problem. It seems that the 32-bit version of v.exe was included in the 64-bit version of Take Command. I guess the 32-bit version of v.exe tries to call from some 64-bit dll or reads from a wrong registry key (32-bit instead of 64-bit), and it fails right there.

C:\Program Files\JPSoft\TCMD13x64>dumpbin v.exe /headers & REM vdebug.exe version
Microsoft (R) COFF/PE Dumper Version 10.00.40219.01
Copyright (C) Microsoft Corporation.  All rights reserved.
Dump of file v.exe
PE signature found
            8664 machine (x64)
C:\Program Files\JPSoft\TCMD13x64>dumpbin vv.exe /headers & REM original v.exe
Microsoft (R) COFF/PE Dumper Version 10.00.40219.01
Copyright (C) Microsoft Corporation.  All rights reserved.
Dump of file vv.exe
PE signature found
             14C machine (x86)
I've kept several old versions, and this seems to be a problem with 13.4.52; 13.3.51 had the proper 64-bit v.exe
  • v.exe inside tcmdx64-13.3.51.exe is version 12.50.04 (and it's 64-bit)
  • v.exe inside tcmdx64-13.4.52.exe is version 13.01.10 (but it's 32-bit)
[FOX] Ultimate Translator