Control Everything CPU usage at startup?

ccb

Jul 13, 2009
47
0
TC v23 on Win10 Pro x64
When the computer starts up Everything starts running, taking >50% of the CPU.
It takes as much as >90% for significant bits of time.
This leaves the computer pretty much unusable...

s there a way to limit the CPU use by Everything?
I don't care if it takes longer to index the disk, I want to be able to use the computer immediately after I log in.
Thanks --
 

ccb

Jul 13, 2009
47
0
That just delays the problem until I first want to use Everything - I start it up and it quickly heads for >90% of the CPU.
Seems like very rude behavior for just about any application or service...
 

ccb

Jul 13, 2009
47
0
I'm running Everything as a service, so it has nothing to do with a TCC session, elevated or otherwise.
If Everything is set to run at startup, TCC is nowhere in sight (unless the Everything service start up TCC for some reason).
Similarly, I can start the Everything UI w/o ever having run TCC.
 

rconn

Administrator
Staff member
May 14, 2008
10,885
97
I'm running Everything as a service, so it has nothing to do with a TCC session, elevated or otherwise.
If Everything is set to run at startup, TCC is nowhere in sight (unless the Everything service start up TCC for some reason).
Similarly, I can start the Everything UI w/o ever having run TCC.
Even if Everything is already running as a service, if you start TCC elevated, you can use the PRIORITY command to bump the Everything service's priority downwards.
 
May 20, 2008
9,144
58
Syracuse, NY, USA
Did you see this one? GUI\Tools\Options\NTFS\<drive>\
Maximum size
Set the maximum size of the USN Journal in KB. If Everything is rebuilding the database after restarting Windows, try increasing this size to at least 32768 KB.
If the journal grows larger than this value it is truncated by removing the specified allocation delta from the beginning of the log.