1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed TCMD 20 beta @REGEXSUB problem

Discussion in 'Support' started by gentzel, Jul 21, 2016.

  1. gentzel

    Joined:
    Sep 24, 2013
    Messages:
    21
    Likes Received:
    0
    Tried out the 20 beta. I use @REGEXSUB heavily in my batch files and it is not functioning properly.

    Simplified example:
    In 17.00.77 x64, this returns "2". In 20beta it returns an empty string.

    I suppose this could have broken in 18 or 19, but given the change of regular expression library in 20 I think it's more likely that it's a regression in the beta.
     
  2. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,885
    Likes Received:
    29
    I get "2" in the 32-bit version of the v20 beta.
    Code:
    v:\> ver & echo %@REGEXSUB[1,"^TCC ([0-9]+)",TCC 2]
    
    TCC  20.00.8  Windows 7 [Version 6.1.7601]
    2
     
  3. gentzel

    Joined:
    Sep 24, 2013
    Messages:
    21
    Likes Received:
    0
    Interesting. Thanks for checking. Perhaps there's something odd about my environment, or it's a 64-bit specific issue.

    Just tried again (I uninstalled 20 but kept the files zipped up in case I wanted to run another test).

     
  4. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,808
    Likes Received:
    82
    Fixed in build 9 (not a bug in the Onigmo library).
     
  5. gentzel

    Joined:
    Sep 24, 2013
    Messages:
    21
    Likes Received:
    0
    Thanks Rex. Very quick fix!
     
  6. gentzel

    Joined:
    Sep 24, 2013
    Messages:
    21
    Likes Received:
    0
    Confirmed fixed in 20.00.9.
     
  7. thorntonpg@gmail.com

    Joined:
    Jul 4, 2008
    Messages:
    187
    Likes Received:
    0
    Found the new beta with option /u installed without a hitch though still had to reconfig everything.exe index and rebuild. dedupe works with embedded white spaces.
     

Share This Page