1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

UTF-8 display in TCMD

Discussion in 'Support' started by nikbackm, Nov 23, 2010.

  1. nikbackm

    Joined:
    May 30, 2008
    Messages:
    194
    Likes Received:
    1
    When I run TCC stand-alone I can TYPE utf8 encoded files correctly by setting the console to code page 65001 using chcp and setting the console font to a font that supports the extended characters in the file (Lucida console).

    However, this does not work if TCC runs inside TCMD. TCMD uses Lucida console font and I have set the code page to 65001. But the extended characters are displayed as gibberish.

    I guess it's the screen-scraping between TCC and TCMD that comes in the way? Any way to fix this by changing an option or so?

    Edit:

    I seem to have found a solution. If I change the font for TCC to Lucida Console and leave that as default for "future windows with same title", then it also seems to work for new TCC sessions run from inside TCMD. (Providing chcp 65001 is used first of course).

    Seems strange to me as TCMD has its own font (also Lucida console) so why should it matter which font the hosted consoles use? Not that I'm complaining as long as it works.
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,870
    Likes Received:
    83
    Windows is translating between the console non-Unicode font and the GUI Unicode font, and it rarely gets all the characters right. The only reliable way to handle this is to have both sides using Unicode code pages.
     

Share This Page