Problem if command prompt is not legacy

#1
Hi Rex

The following problem exist - at least under Windows 10 Creators Update [Version 10.0.15063] Pro 64-Bit with TCMD 20.11.46 x64 / 21.00.14 Beta RC1 x64 - if the Command Prompt is NOT configured as LEGACY Console and if the Account is NOT elevated (as Restricted User and NOT as Admin) and after I changed the font (with bigger size also):

1) Even SOMETIMES after start a first not normal additional SPACE is displayed ...

This can be "solved" with a CLS ...

2) Then after - for example command POWERCFG /? - the following happens:
First, the display is okay yet ...


After I scroll up and down (a bit), the display is no more okay ...


So, that means:
- Even if I change the font back (on command prompt AND TCMD/TCC to Consolas 12) the effect remains!
- With bigger font sizes the effect is stronger!
- I had (till now) this effect NOT under my admin (elevated) account!
- If I change the console prompt to same setting how for legacy console, the effect remains! Only if I change the console prompt really to legacy, all is okay again.

- Personally I can life with that problem because for me it's okay to switch the console prompt to legacy.

Kind regards
 
#4
It's a Windows (or video driver) bug, not TCC or TCMD.

I cannot reproduce it here with the current Windows 10 Creators Update (I did see it occasionally with the beta Creators Update).
Thanks, Rex.
The question is (for me) why only in non-elevated account ... if it's really a video driver bug, I would expect also in the elevated account ... but okay even THEN it's nevertheless possible ...