1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TCMD 14 Ignores Argument

Discussion in 'Support' started by Jay Sage, Jun 12, 2012.

  1. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    When I launch TCMD 14 with a shortcut comtaining the command

    "C:\Program Files\JPSoft\TCMD14x64\tcmd.exe" /@C:\Users\Jay\AppData\Local\JPSoft\tcmd14.ini

    or if I issue that command from the command with (with or without the '/' before '@', the argument is ignored. The variable %_ininame says that the INI command is tcmd.ini, not tcmd14.ini.

    Am I doing something wrong, or is this a bug. Is there a better way to keep my configurations for version 13 and 14 separate from each other?

    Now I see that with version 13, launching TCC with that argument (but with 13 instead of 14) also fails to access the designated INI file. But an INI file in "C:\Program Files\JPSoft\TCMD13x64" is used. I must be forgetting how these arguments work.

    -- Jay
     
  2. David Marcus

    Joined:
    Jun 4, 2008
    Messages:
    646
    Likes Received:
    1
    Isn't %_ininame the ini file for the shell, not for TCMD?
     
  3. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,792
    Likes Received:
    29
    You're telling TCMD to start with that INI file and it probably is doing do. But _ININAME gives the INI file used by TCC. You might do well to edit COMSPEC in the options for a particular TCMD and specify there the INI file you want the default TCC to use.
     
  4. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    Or in a TAB section of TCMD. If TCC in a TCMD tab uses the same INI file as TCMD itself, its _ININAME will point to the shared INI file.
     
  5. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    I had the same thought, but as I wrote in my original message, I tried running a TCC command (not TCMD) with the same argument and got the same result.

    I just went into my TCMD14 configuration to try adding the argument to the COMSPEC and tab command line -- and I noticed something strange. Although %_ininame reports TCMD.INI, the top border of the TCMD option screen shows TCMD14.INI! Something doesn't seem right here. And checking the time stamps on the files, I see that TCMD14.INI is the one being changed.

    Well, this may be the result of the change taking effect the minute I saved the configuration. A new TCC tab reports %_ininame with TCMD14.INI.

    Now I went back and tried to make a similar change in TCMD13, and the INI file did not change for the current tab. Oh, that's probably because the current INI file location is in the program files directory, so I probably have to open TCMD in admin mode to make any changes. What's the chance that I'll remember all this when version 15 comes out!!!

    -- Jay
     
  6. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    The answer is simple.Do not install in the default locations. My installations are in F:\JPSOFT\Inn, where nn=05, 06, ..., 14 (I stands for "interpreter"). My .INI files are actually in F:\JPSOFT, which is also my startup directory, and named Vnn.INI. Each version has its own desktop shortcut; the most recent versions even have hotkeys. One of the nice things about WinXP hotkeys is that if the version is already running, but is not the foreground window, e.g., it is minimized, the hotkey brings it into the foreground, so I can immediately start typing.
     
  7. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,792
    Likes Received:
    29
    If, in TCMD, you go to Options\Configure (either TCMD or TCC) you're going to be configuring the INI file that TCMD was started with. TCMD does not keep track of the fact that your COMSPEC specifies a different INI file for TCC (COMSPEC may not point to TCC at all). If, inside TCMD, you want to get at the INI file used by a TCC, use TCC's OPTION command.
     

Share This Page