TCMD.INI: The "super hidden" problem ...

#1
Hi Rex

The following problem exist with TCMD 20.11.46 x64 / 21.00.14 Beta RC1 x64:

For me it's important to have in TCMD.INI the following:

ShowSuperHidden=Yes

However (for example) after [Optionen, Take Command, Registrieren] (probably [Options, Take Command, Register] in english), this setting is switched back to ...

ShowSuperHidden=No

This is not really good because HERE it's important that this setting is ALWAYS = Yes ... because I have to see those super hidden files also while TCMD is open!

Can you solve that problem?

Kind regards
 
#3
Thanks Rex

I can always reproduce that (in both versions). And yes, I took the right INI.

And I know probably WHY is that so - at least I hope I am right ;-)

First ... If I begin with a "clean" TCMD.INI, there is NO such setting in the INI. This setting (superhidden and others) are added only after certain step(s) as the example step above! And this is then ALWAYS ShowSupperHidden=No ... so I I repeat this step later, it's ShowSuperHidden=No again - regardless the setting before ...

Please see also this thread here, where another user explains that effect with adding those settings too:

[TC rearranges my desktop!]

This means: this entry was DEFINITIVE added while I was within the TCMD config on register tab (and highly probably through TCMD).

I hope you can understand my "english" ... else I will TRY to explain better ;-)
 

rconn

Administrator
Staff member
May 14, 2008
10,597
97
#4
First ... If I begin with a "clean" TCMD.INI, there is NO such setting in the INI. This setting (superhidden and others) are added only after certain step(s) as the example step above! And this is then ALWAYS ShowSupperHidden=No ... so I I repeat this step later, it's ShowSuperHidden=No again - regardless the setting before ...
WAD - when TCMD.INI is updated, TCMD (or TCC) will add default values for any missing INI directives. (If you don't see a "ShowSuperHidden" directive in TCMD.INI, it will always default to "no".)

Please see also this thread here, where another user explains that effect with adding those settings too:

[TC rearranges my desktop!]
This is a somewhat different topic - the user wanted to have different Explorer settings in the desktop vs. TCMD. (That's not possible; Explorer settings are always global.)

This means: this entry was DEFINITIVE added while I was within the TCMD config on register tab (and highly probably through TCMD).
The directive would be *added* in this example, but not *changed* (which is what you were implying in your first message).

ShowSuperHidden defaults to "no", and there is no option to change it in the configuration dialogs. However, once you edit your TCMD.INI to explicitly set it to "yes", it should stay set until you edit your TCMD.INI file again to change it.

To verify:

Create your TCMD.INI
Use your editor to change (or add) the ShowSuperHidden=yes directive in the [TakeCommand] section
All subsequent modifications to TCMD.INI by TCMD should preserve the ShowSuperHidden-yes setting.
 
#5
Thank you Rex for your answer...

This is a somewhat different topic - the user wanted to have different Explorer settings in the desktop vs. TCMD. (That's not possible; Explorer settings are always global.)
I meant only the process for ADDING those settings in INI not the other things ... sorry, if that was confused ...

The directive would be *added* in this example, but not *changed* (which is what you were implying in your first message).

ShowSuperHidden defaults to "no", and there is no option to change it in the configuration dialogs. However, once you edit your TCMD.INI to explicitly set it to "yes", it should stay set until you edit your TCMD.INI file again to change it.

To verify:

Create your TCMD.INI
Use your editor to change (or add) the ShowSuperHidden=yes directive in the [TakeCommand] section
All subsequent modifications to TCMD.INI by TCMD should preserve the ShowSuperHidden-yes setting.
Exactly this happens, after those entries were added in my INI, EACH time I repeat the step, it CHANGES to no (maybe it removes the line and add this line with "no" again. This is really EACH time the case!

BUT I was wrong with the register tab, it's not the register tab which reproduces it - SORRY SORRY!!

Here the exact steps to reproduce it:

1) See here my TCMD.INI (see the path in image, if this is interesting too) with ShowSuperHidden=Yes:



2) Open TCMD and go to [Options, Take Command, Advanced] and change the setting in the red square ...



3) Close TCMD

4) Check TCMD.INI and see ...



Between those steps were only seconds and I can this repeat and repeat with always the same result ...

Greetings


PS: This was even the case on "old" TCMD 20.x on older Windows 10 Pro x64 version too and since then I made a new CLEAN OS install with the newest Win 10 "Creator"!

PPS: I could even install a screen capture video software and record a video to proof it, if it's really necessary ...